Skip to main content

Pengertian dan Simulasi Cara Konfigurasi Routing BGP (Border Gateway Protokol)

Pengertian dan Konfigurasi Routing BGP (Border Gateway Protokol)

Materi pembelajaran kali ini masih pada penggunaan jenis routing dinamis, yang dibahas terkait pengertian dan konfigurasi routing BGP (Border Gateway Protokol).

Pengertian Routing BGP 

Border Gateway Protocol atau yang dikenal sebagai routing BGP ini adalah, salah satu alternatif pilihan routing dinamis sebagai penghubung network pada perangkat router.

BGP fungsikan sebagai koneksi antar Autonomous System (AS), yang dimana penggunaannya sering digunakan pada jaringan komputer yang besar, misalnya penyedia layanan ISP.

Routing BGP masih termasuk dalam kategori jenis routing protokol Exterior Gateway Protokol atau EGP. Bisa dibilang juga, bahwasanya penggunaan routing ini memiliki jangkauan skalabilitas yan tinggi. Karena pada dasarnya cara kerja BGP yaitu untuk melayani pertukaran data routing pada jaringan-jaringan organisasi besar seperti intansi pemerintah dan perusahaan.

Maka dari itulah BGP dikenal dengan julukan routing protokol yang sangat kompleks. Seperti halnya di Indonesia, ada kemungkinan penyedia jaringan ISP untuk menghubungkan network antar wilayah. Dalam hal ini dapat menggunakan routing BGP dalam pembangunan inftrastruktur jaringan yang menggunakan perangkat router.

Mengapa Pilih BGP?

Penggunaan BGP sebagai penghubung antar network, memungkinkan router dapat memproses serta mengontrol setiap bagian dari trafik pertukaran data dari sumber informasi yang berbeda didalam sebuah sistem network multi-home istilah lainya tersambung antara satu jaringan ke lebih dari 1 layanan ISP.

Tujuan penggunaan BGP yaitu agar network dapat diketahui oleh network lainya atau diluar network (upsteram provider atau peer) terkait pemilihan jalur pertukaran data atau porsi dari address network yang meminta izin serta membawa data dari satu tempat ke network tempat tujuan (meng-advertise).

Mungkin ini bisa dikatakan kelemahan dari routing BGP, yaitu proses pada saat ingin mempublikasikan jalur network tidak diketahui bagaimana cara mencapai ke tempat tujuanya. Istilah tersebut dinamakan black-holing, yaitu melakukan yang namanya perizinan atau advertise untuk membawa informasi  routing data, namun ada beberapa bagian address merupakan milik network orang lain. Sehingga berakibat proses advertise ini dapat menyulitkan atau membutuhkan waktu yang cukup panjang.

Simulasi Konfigurasi Routing BGP

Ada baiknya untuk melakukan simulasi routing agar dapat menambah gambaran bagaimana BGP itu bekerja. Buatlah topologi seperti pada gambar dibawah ini. 

Simulasi Konfigurasi Routing BGP


Konfigurasi IP pada Port Router-BGP-1 dan Routing

Router>en 
Router#conf t 
Router(config)#hostname Router-BGP-1 
Router-BGP-1(config)#interface FastEthernet0/0 
Router-BGP-1(config-if)#ip address 20.20.20.1 255.255.255.252 
Router-BGP-1(config-if)#no shut 
Router-BGP-1(config-if)#exit 
Router-BGP-1(config)#interface FastEthernet0/1 
Router-BGP-1(config-if)#ip address 192.168.1.1 255.255.255.0 
Router-BGP-1(config-if)#no shut 
Router-BGP-1(config-if)#exit 
Router-BGP-1(config)#router bgp 100 
Router-BGP-1(config-router)#neighbor 20.20.20.2 remote-as 200 
Router-BGP-1(config-router)#network 192.168.1.0 mask 255.255.255.0  
Router-BGP-1(config-router)#exit 
Router-BGP-1(config)#do wr 
Building configuration... 
[OK]


Konfigurasi IP pada Port Router-BGP-2 dan Routing

Router>en 
Router#conf t 
Router(config)#hostname Router-BGP-2 
Router-BGP-2(config)#interface FastEthernet0/0 
Router-BGP-2(config-if)#ip address 20.20.20.2 255.255.255.252 
Router-BGP-2(config-if)#no shut 
Router-BGP-2(config-if)#exit 
Router-BGP-2(config)#interface FastEthernet0/1 
Router-BGP-2(config-if)#ip address 172.16.10.1 255.255.255.0 
Router-BGP-2(config-if)#no shut 
Router-BGP-2(config-if)#exit 
Router-BGP-2(config)#router bgp 200 
Router-BGP-2(config-router)#neighbor 20.20.20.1 remote-as 100 
Router-BGP-2(config-router)#%BGP-5-ADJCHANGE: neighbor 20.20.20.1 Up 
Router-BGP-2(config-router)#network 172.16.10.0 mask 255.255.255.0

Router-BGP-2(config-router)#exit
 
Router-BGP-2(config)#do wr 
Building configuration... 
[OK]

Konfigurasi IP pada Port Router-BGP-2 dan Routing

Konfigurasi IP  pada Masing-Masing PC

Sesuaikan ip address PC sesuai dengan network yang akan digunakan, dan pada PC dibawah ini di setting berdasarkan IP gateway Router-BGP-1.

Konfigurasi IP  pada Masing-Masing PC Pada Simulasi Jaringan BGP

Pengetesan Ping IP antar PC yang berbeda Network

Bila hasil pengetesan antar perangkat PC sudah berhasil, kurang lebih tampilannya seperti pada gambar ping di bawah ini. Namun jika kamu masih ada DHU atau RTO, sebaiknya cek kembali apakah konfigurasi port pada masing-masing router sudah sesuai, begitupun pastikan IP pada PC sudah benar.

Pengetesan Ping IP antar PC yang berbeda Network Pada Simulasi Routing BGP

Demikianlah pembahasan terkait pengertian dan konfigurasi routing BGP menggunakan 2 router, 2 switch dan 2 PC. Semoga dapat menambah wawasan kamu dalam implementasi routing antar network menggunakan BGP. 
Comment Policy: Silahkan tuliskan komentar, kritik maupaun saran kamu berdasarkan pembahasan yang sesuai dengan halaman ini. Kamu juga dapat menghubungi OmahJaringan melalui halaman kontak.
Buka Komentar
Tutup Komentar